Здравствуйте. Воюю с проблемой уже 2 месяца:
При соединении Астериска 1.8 с Cisco 3660 по SIP ( h323) протоколу, с помощью кодека g723 (g723r53) звонящий слышит собеседника хорошо, однако вызываемый со стороны циски часто слышит искажение речи (металлический тембр голоса, нечеткость слов) . Когда звонишь с циски на астериск используя кодек GSM все нормально. Пинг в хороший, debug rtp сбоев на астериске не показывает.
Параметры Астериска:
exten => _9XXX,1,Dial(SIP/${EXTEN:1}@ToCisco,20)
exten => _9XXX,n,Hangup()

[ToCisco]
type=peer
ip=10.248.xx.xx ;ip cisco
port=5060

Кодек g723 загружен и установлен согласно текущей архитектуры ПК.(iCeleron 4 -2,6/768/40)
В файл /etc/asterisk/codec.conf добавлены строки:

[g723]
; 6.3Kbps stream
;default sendrate=63
sendrate=53

Вижу два пути решения:
1-1)Решил сделать кодек входящий для циски тоже gsm, так как на исходящей связи он работает стабильно но cisco упрямо не хочет принимать любой другой кодек кроме g723: если указать другой кодек в дефолтной настройке циски то астериск соединяется по gsm, однако отваливаться другие абоненты соединяющееся с этой циской по g723.
1)Вот и возникает вопрос как сконфигурировать циску 3660 так чтобы можно было по GSM и по g723 c ней одновременно соединять ? Если можно ответьте с небольшим примером.

2)Есть подозрение что эффект искажения голоса появляется из за VAD (CNG), который к сожалению неподерживает астериск, но используется циской. Я в каждом dial-peer`е добавил "no vad" однако при дебуге циске все равно проскакивает его включение, при входящем вызове.
2-2)Как полностью выключить VAD (CNG) на циске?
п.с. Вызов со стороны астериска производил с нескольких разных софтфонов, и spa504g с выключенным на них VAD (CNG), тот же дефект голоса обнаружился и на cisco 1700 c VOIP 2x модулем для подключения аналоговых телефонов.